API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InputDefinitionFactoryGetDrawingObject Method

Gets the object from the given single-object input.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public static DrawingObject GetDrawingObject(
	DrawingPluginBaseInputDefinition input
)

Parameters

input
Type: Tekla.Structures.PluginsDrawingPluginBaseInputDefinition
The input.

Return Value

Type: DrawingObject
The object.
See Also