API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingCreatorCreateDrawings Method (AutoDrawingRule, Identifier, AutoDrawingsStatusEnum)

Creates drawings using the AutoDrawing tool of Tekla Structures.

Namespace:  Tekla.Structures.Drawing.Automation
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public static bool CreateDrawings(
	AutoDrawingRule Rule,
	Identifier ModelObjectIdentifier,
	out AutoDrawingsStatusEnum OperationStatus
)

Parameters

Rule
Type: Tekla.Structures.Drawing.AutomationAutoDrawingRule
The AutoDrawing rule to be used.
ModelObjectIdentifier
Type: Tekla.StructuresIdentifier
The model object identifier to be used. Part identifier to create single part drawing or assembly identifier to create assembly drawing.
OperationStatus
Type: Tekla.Structures.Drawing.AutomationAutoDrawingsStatusEnum
The operation status to be used.

Return Value

Type: Boolean
True on success.
See Also