API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewMarkBasicSymbolAttributes Class

The ViewMarkBasicSymbolAttributes class contains basic attributes for mark symbols.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public abstract class ViewMarkBasicSymbolAttributes : GenericAttributesBase

The ViewMarkBasicSymbolAttributes type exposes the following members.

Constructors
  NameDescription
Public methodViewMarkBasicSymbolAttributes
Creates a new mark symbol attributes instance.
Public methodViewMarkBasicSymbolAttributes(Double, MarkSymbolShape)
Creates a new mark symbol attributes instance with the given size and shape.
Top
Properties
  NameDescription
Public propertyShape
The shape of the mark symbol.
Public propertySize
The size of the mark symbol.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also