API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Text Constructor (ViewBase, Point, String, PlacingBase)

Creates a new text instance with the given text string using a specific placing type.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public Text(
	ViewBase view,
	Point insertionPoint,
	string text,
	PlacingBase Placing
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The insertion point to be used.
text
Type: SystemString
The text string to be used.
Placing
Type: Tekla.Structures.DrawingPlacingBase
The placing type to be used.
See Also