API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Symbol Constructor (ViewBase, Point, SymbolInfo, SymbolSymbolAttributes, PlacingBase)

Creates a new symbol instance using the given attributes and placing.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public Symbol(
	ViewBase View,
	Point InsertionPoint,
	SymbolInfo SymbolInfo,
	SymbolSymbolAttributes Attributes,
	PlacingBase Placing
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view where to insert the symbol.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location where to place the symbol.
SymbolInfo
Type: Tekla.Structures.DrawingSymbolInfo
The symbol information to be used.
Attributes
Type: Tekla.Structures.DrawingSymbolSymbolAttributes
The symbol attributes to be applied.
Placing
Type: Tekla.Structures.DrawingPlacingBase
The way the object is placed.
See Also