API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SectionMark Constructor (View, Point, Point)

Creates a new section mark instance with the given positions.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public SectionMark(
	View view,
	Point leftPoint,
	Point rightPoint
)

Parameters

view
Type: Tekla.Structures.DrawingView
The view to be used.
leftPoint
Type: Tekla.Structures.Geometry3dPoint
The starting point of the left side of the new section mark.
rightPoint
Type: Tekla.Structures.Geometry3dPoint
The starting point of the right side of the new section mark.
See Also