API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModelReferenceModelAttributes Class

The ReferenceModelAttributes class contains attributes for reference model objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingReferenceModelReferenceModelAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public sealed class ReferenceModelAttributes : AttributesBase

The ReferenceModelReferenceModelAttributes type exposes the following members.

Constructors
  NameDescription
Public methodReferenceModelReferenceModelAttributes
Creates a new default reference model attributes instance that loads standard attributes.
Top
Properties
  NameDescription
Public propertyColor Obsolete.
Public propertyLine
Gets or sets the line type.
Public propertyLineType Obsolete.
Top
Methods
See Also