![]() | Rectangle Constructor (ViewBase, Point, Double, Double, RectangleRectangleAttributes) |
Creates a new rectangle instance with the start point and the defined width and height using the given attributes.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611

public Rectangle( ViewBase view, Point startPoint, double width, double height, RectangleRectangleAttributes attributes )
Parameters
- view
- Type: Tekla.Structures.DrawingViewBase
The view to be used. - startPoint
- Type: Tekla.Structures.Geometry3dPoint
The start point to be used. - width
- Type: SystemDouble
The width to be used. - height
- Type: SystemDouble
The height to be used. - attributes
- Type: Tekla.Structures.DrawingRectangleRectangleAttributes
The rectangle attributes to be used.