API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PropertyElementPropertyElementTypeChamferMarkPropertyElementTypes Class

The ChamferMarkPropertyElementTypes class represents the available property element types for chamfer marks.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPropertyElementPropertyElementTypeChamferMarkPropertyElementTypes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public static class ChamferMarkPropertyElementTypes

The PropertyElementPropertyElementTypeChamferMarkPropertyElementTypes type exposes the following members.

Methods
  NameDescription
Public methodStatic memberDX
Returns the change in the X direction property element type.
Public methodStatic memberDY
Returns the change in the Y direction property element type.
Public methodStatic memberLength
Returns the length property element type.
Public methodStatic memberName
Returns the name property element type.
Top
See Also