API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PourBreakPourBreakAttributes Class

The PourBreakAttributes class is the attributes class for the pour break.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingPourBreakPourBreakAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public sealed class PourBreakAttributes : AttributesBase

The PourBreakPourBreakAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPourBreakPourBreakAttributes
Creates a new default pour break attributes instance that loads standard attributes.
Public methodPourBreakPourBreakAttributes(String)
Creates a new pour break attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyDrawHiddenLines
Indicates whether hidden lines are used to draw the pour break or not.
Public propertyHiddenLines
The hidden line type of the pour break.
Public propertyVisibleLines
The visible line type of the pour break.
Top
Methods
See Also