API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Polyline Constructor (ViewBase, PointList)

Creates a new polyline instance with the point list using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public Polyline(
	ViewBase view,
	PointList pointList
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
pointList
Type: Tekla.Structures.DrawingPointList
The point list to be used.
See Also