API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Polygon Constructor (ViewBase, PointList, PolygonPolygonAttributes)

Creates a new polygon instance with the point list using the given attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public Polygon(
	ViewBase view,
	PointList pointList,
	PolygonPolygonAttributes attributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
pointList
Type: Tekla.Structures.DrawingPointList
The point list to be used.
attributes
Type: Tekla.Structures.DrawingPolygonPolygonAttributes
The polygon attributes to be used.
See Also