API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PointListAdd Method

Adds a new point to the end of the point list.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public int Add(
	Point value
)

Parameters

value
Type: Tekla.Structures.Geometry3dPoint
The point to be added to the list.

Return Value

Type: Int32
The index where the point was added.
See Also