API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginApplyStandardValues Method

Applies the values of the specified file as the default values for the dialog belonging to this plug-in. This will affect each Insert call of the plug-ins with the same name.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public bool ApplyStandardValues(
	string Filename
)

Parameters

Filename
Type: SystemString
The short name of the file containing the attributes.

Return Value

Type: Boolean
True on success. Otherwise, false.
See Also