API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Plugin Constructor

Creates a new plug-in instance.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public Plugin(
	ViewBase View,
	string Name
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view to be used.
Name
Type: SystemString
The plug-in name to be used.
See Also