API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingQuarterAttributes Constructor (Boolean, Boolean, Boolean, Boolean)

Creates a new placing quarter attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public PlacingQuarterAttributes(
	bool TopLeft,
	bool TopRight,
	bool BottomLeft,
	bool BottomRight
)

Parameters

TopLeft
Type: SystemBoolean
Defines whether the object can search for a suitable location in the top left direction.
TopRight
Type: SystemBoolean
Defines whether the object can search for a suitable location in the top right direction.
BottomLeft
Type: SystemBoolean
Defines whether the object can search for a suitable location in the bottom left direction.
BottomRight
Type: SystemBoolean
Defines whether the object can search for a suitable location in the bottom right direction.
See Also