API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingAttributes Constructor (Boolean, PlacingDistanceAttributes, PlacingQuarterAttributes)

Creates a new placing quarter attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public PlacingAttributes(
	bool IsFixed,
	PlacingDistanceAttributes PlacingDistance,
	PlacingQuarterAttributes PlacingQuarter
)

Parameters

IsFixed
Type: SystemBoolean
Defines whether the object is using fixed or free placing.
PlacingDistance
Type: Tekla.Structures.DrawingPlacingDistanceAttributes
The distances to be used for the placing.
PlacingQuarter
Type: Tekla.Structures.DrawingPlacingQuarterAttributes
The directions in which the placing can find suitable locations.
See Also