API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputThreePoints Constructor

Creates a new PickerInputThreePoints instance with one point selected in a view.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public PickerInputThreePoints(
	ViewBase pickedView,
	Point firstPickedPoint,
	Point secondPickedPoint,
	Point thirdPickedPoint
)

Parameters

pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
firstPickedPoint
Type: Tekla.Structures.Geometry3dPoint
The first picked point in the view coordinates.
secondPickedPoint
Type: Tekla.Structures.Geometry3dPoint
The second picked point in the view coordinates.
thirdPickedPoint
Type: Tekla.Structures.Geometry3dPoint
The third picked point in the view coordinates.
See Also