API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputObjectAndAPoint Constructor

Creates a new PickerInputObjectAndAPoint instance representing the pick of a drawing object and the coordinates of the point used to pick the object.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public PickerInputObjectAndAPoint(
	DrawingObject pickedObject,
	Point pickedPoint
)

Parameters

pickedObject
Type: Tekla.Structures.DrawingDrawingObject
The picked drawing object.
pickedPoint
Type: Tekla.Structures.Geometry3dPoint
The picked point in the picked object view coordinates.
See Also