API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputNPoints Constructor

Creates a new PickerInputNPoints instance representing N points selected in a view.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public PickerInputNPoints(
	ViewBase pickedView,
	PointList pickedPoints
)

Parameters

pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
pickedPoints
Type: Tekla.Structures.DrawingPointList
The list of picked points in the view coordinates.
See Also