API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LayoutAttributesLoadAttributes Method

Loads drawing layout attributes from the specified attribute file.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public override bool LoadAttributes(
	string AttributeFile
)

Parameters

AttributeFile
Type: SystemString
The name of the drawing attribute file. E.g. "standard".

Return Value

Type: Boolean
True if the attributes are loaded correctly. False if the attribute file loading failed.
See Also