API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerUpdateDrawing Method

Updates the drawing. This is the same as pressing Update on the drawing list for a selected drawing. NOTE! The drawing cannot be active, otherwise the operation fails. NOTE! Numbering must be executed before this operation.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public bool UpdateDrawing(
	Drawing drawing
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be updated.

Return Value

Type: Boolean
True on success.
See Also