API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CustomLineType Class

The CustomLineType class defines the custom line types of the drawing objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public class CustomLineType : LineTypes, 
	ICloneable

The CustomLineType type exposes the following members.

Properties
  NameDescription
Public propertyDescription
The Description of the custom line type (ASCII representation of the line).
Public propertyLineDescription
The description of the custom line type. Description uses the following format: List of line segments. Positive value gives length of filled line segment and negative value gives length of empty line segment. 0 means a dot.
Public propertyName
The Name of the custom line type.
Top
Methods
Operators
  NameDescription
Public operatorStatic memberEquality
Returns true if the current object and the given object are equal.
Public operatorStatic memberInequality
Returns true if the current object and the given object are not equal.
Top
See Also