API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CastUnitDrawing Constructor (Identifier, String)

Instantiates a new cast unit drawing with given attributes for a given cast unit.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public CastUnitDrawing(
	Identifier castUnitIdentifier,
	string AttributeFile
)

Parameters

castUnitIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object cast unit.
AttributeFile
Type: SystemString
The filename of the attributes file.
See Also