API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CannotSetAttributeForPluginException Class

The CannotSetAttributeForPluginException class defines the exception that is thrown when Plugin.SetAttribute is called but the attribute cannot be set.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public class CannotSetAttributeForPluginException : TeklaStructuresDrawingsApplicationException
Constructors
  NameDescription
Public methodCannotSetAttributeForPluginException
Creates a new CannotSetAttributeForPluginException instance.
Public methodCannotSetAttributeForPluginException(String)
Creates a new CannotSetAttributeForPluginException instance.
Top
See Also