API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CannotModifyNonActiveDrawingException Class

The CannotModifyNonActiveDrawingException class defines the exception that is thrown when a user tries to modify a drawing that is not set as active.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public class CannotModifyNonActiveDrawingException : TeklaStructuresDrawingsApplicationException

The CannotModifyNonActiveDrawingException type exposes the following members.

Constructors
  NameDescription
Public methodCannotModifyNonActiveDrawingException
Creates a new cannot modify non-active drawing exception instance.
Top
See Also