API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AssemblyDrawing Constructor (Identifier, Int32, String)

Instantiates a new assembly drawing with given attributes and with a specified sheet number.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public AssemblyDrawing(
	Identifier assemblyIdentifier,
	int sheetNumber,
	string AttributeFile
)

Parameters

assemblyIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object assembly
sheetNumber
Type: SystemInt32
The sheet number of the drawing.
AttributeFile
Type: SystemString
The filename of the attributes file.
See Also