API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleDimension Constructor (ViewBase, Point, Point, Point, Double, AngleDimensionAttributes)

Creates a new angle dimension instance using three points.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public AngleDimension(
	ViewBase View,
	Point Origin,
	Point Point1,
	Point Point2,
	double Distance,
	AngleDimensionAttributes Attributes
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view to be used.
Origin
Type: Tekla.Structures.Geometry3dPoint
The origin to be used.
Point1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used.
Point2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used.
Distance
Type: SystemDouble
The distance of the angle sign from the origin to the first point.
Attributes
Type: Tekla.Structures.DrawingAngleDimensionAttributes
The angle dimension attributes to be used.
See Also