API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AlongLinePlacing Constructor

Creates a new along line placing instance. The given two points define the line to be used for the placing.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public AlongLinePlacing(
	Point StartPoint,
	Point EndPoint
)

Parameters

StartPoint
Type: Tekla.Structures.Geometry3dPoint
The first point of the line.
EndPoint
Type: Tekla.Structures.Geometry3dPoint
The second point of the line.
See Also