![]() | ShapeSelectionForm Class |
The ShapeSelectionForm class represents a dialog to select Shapes
using the Shape catalogs.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsShapeSelectionForm
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsShapeSelectionForm
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611

The ShapeSelectionForm type exposes the following members.

Name | Description | |
---|---|---|
![]() | ShapeSelectionForm(ListShapeItem) |
Initializes a new instance of the ShapeSelectionForm class.
|
![]() | ShapeSelectionForm(ListShapeItem, String) |
Initializes a new instance of the ShapeSelectionForm class, selecting the given Shape in the tree control.
|

Name | Description | |
---|---|---|
![]() | SelectedShape |
Gets or sets the selected Shape in the control.
|