Tekla Tedds API 2022 Release Notes
Updated:
25 Apr 2022
Tekla.Structural.InteropAssemblies.Tedds
Changes to the Tedds Application API.
IProject Interface
- Added a new method IsOpen which can be used to determine whether a Tedds project is currently open.
- Added a new method SetBimProject which allows the Tedds project to be linked to an external BIM project.
- Added a new property BIMProject for retrieving information about a BIM project linked to the current Tedds project.
- Added a new method SaveAsPdf which allows all the documents in a Tedds project to be saved in PDF format as separate files or a single file.
_IApplicationEvents
- Added a new interface _IApplicationEvents for events which are raised by the Tedds application.
- Added a new event ProjectCreated which is raised when a new Tedds project is created.
- Added a new event ProjectdOpened which is raised when a Tedds project is opened.
- Added a new event ProjectClosed which is raised when the current Tedds project is closed.
Tekla.Structural.InteropAssemblies.TeddsCalc
Changes to the TeddsCalculator API.
ICalculator Interface
- Removed Login method from ICalculator interface