Tekla Structures 2022 Open API Release Notes
Updated:
29 Sep 2022
TEKLA.STRUCTURES.ANALYSIS 2022.0.0.0. ASSEMBLY
- Fixes, such as modifying the connectivity attributes, have been made in the AnalysisEdge Modify operation.
TTSD-43316
TEKLA.STRUCTURES.CATALOG 2022.0.0.0. ASSEMBLY
- ProfileItem has a new method GetHighAccuracyCrossSection. CrossSection has a new Select - method and two methods (GetOuterContour, GetInnerContours) to get a Polycurve that represents contours.
TTSD-43220 - The Tekla.Structures.CatalogInternal.ShapeHandler.Import method functionality has been changed so that if the ImportEntry.Overwrite is set to true and the importing is done on an archive (TSC) file, the metadata of the new file overwrites the existing metadata for that shape in the Shape Catalog.
TTSD-46698
TEKLA.STRUCTURES.DATATYPE 2022.0.0.0. ASSEMBLY
- It is now possible to use decimal input for distance values without the feet mark if the unit type used is Distance.UnitType.Foot
TTSD-44181
TEKLA.STRUCTURES.DIALOG 2022.0.0.0 ASSEMBLY
- There were problems in releasing memory of dialog boxes inherited from PluginWindowBase. This has now been fixed.
TTSD-47597 - Problems in getting the values for plugins from reopened Wpf dialogs have been fixed.
TTSD-48522 - Improved the performance of the OpenAPI Assembly.Modify function when used with very large assemblies.
TTSD-49602 - When the system closed the Wpf plugin dialog box, an exception might have been raised. This has now been fixed.
TTSD-50031
TEKLA.STRUCTURES.PLUGINS.DIRECTMANIPULATION 2022.0.0.0 ASSEMBLY
- Support to create direct modification, creation and modification features have been added to CustomPartBase plug-ins.
TTSD-44750
TEKLA.STRUCTURES.DRAWINGS 2022.0.0.0. ASSEMBLY
- In straight dimensions, MiddleLowerTag, DimensionValuePostfix, and DimensionValuePrefix are now taken from the Straightdimensionsetattributes when using the constructor that takes those attributes as a parameter.
TTSD-36316
- The restriction box of the drawing view no longer influences the results of the GetCutPart() command.
TTSD-43097
- The drawing API GetAllViews now works more reliably.
TTSD-45422
- InsertionPoint and BoundingBoxes now work for WeldMark objects.
TTSD-46436
- A new method SortObjectsByPresentationOrder() has been added to the Operation class in the Tekla.Structures.Drawing.Operations namespace for sorting drawing objects in presentation order from bottom to top.
TTSD-47706
TEKLA.STRUCTURES.MODEL 2022.0.0.0. ASSEMBLY
- Implemented changes to the Assembly object in the OpenAPI to support rebar assemblies.
TTSD-42547 - Getting string values longer than 80 characters from components now works correctly again.
TTSD-43553 - Model objects can now be exported in the IFC4 file format using methods of Operations class:
- CreateIFC4ExportFromSelected
- CreateIFC4ExportFromAll
TTSD-45753
- Point cloud offsets and rotation properties can now be retrieved correctly through OpenAPI.
TTSD-46278 - When using GetAllObjectsWithType method and filtering by Part, lofted plate and spiral beam objects were not returned. This has now been fixed.
TTSD-47536 - Previously, in some rare cases lofted plates with arc base curves generated an exception when they were selected. This has now been fixed.
TTSD-45563 - When creating a rebar assembly, the OpenAPI Assembly.Insert function now automatically selects the rebar with the highest weight as the main object if there is no call to Assembly.SetMainObject to explicitly set the main object.
TTSD-49595 - The performance of the GetDynamicStringProperty() method with large strings in model objects has been improved significantly.
TTSD-49700
TEKLA.STRUCTURES.PLUGINS 2022.0.0.0 ASSEMBLY
- PluginPropertyFileLocationAttribute was added.
TTSD-42420 - Copying custom part plug-in objects did not work correctly if position attributes and offsets were used. The objects were copied to the wrong position. This has now been fixed.
TTSD-45046 - It is now possible to store long DistanceList values for plug-ins with .NET UI (using with Forms or Wpf)
TTSD-45615 - Plug-ins defined with coordination system type FROM_FIRST_AND_SECOND_POINT now keep the original rotation regardless of the current model workplane used in the modification.
TTSD-46652
Other Open API changes
- An additional check has been added to the TSEP file build process to check that the Product Version has only Major/Minor values specified and that they fall within the allowable range of 0.1 - 0.254. If this check fails, the build fails and a message describing the problem is written to the log.
This check fixes an issue where the upgrade failed because versions such as 1.0.0 were used for a first release and 1.0.1 for a second release, but TSEP only used the major/minor values to conform to the versioning rules for Tekla Warehouse.
TTSD-45373 - When building a TSEP package using the builder tool in one Tekla Structures version and then using that tool to install the TSEP to a different Tekla Structures version, any exe.config generated was not configured correctly. This has now been fixed.
TTSD-36787 - Previously, GetMultiDirectoryFileList did not return files in subfolders of XS_FIRM/XS_PROJECT. This has now been fixed.
TTSD-43249 - Sometimes an application or plug-in using the OpenAPI to add a view caused Tekla Structures graphics pipeline to crash. This has now been fixed.
TTSD-48899
RPC changes
- New RPC API functions for rebar assemblies (xsCreateRebarAssembly, xsAddToRebarAssembly, xsRemoveFromRebarAssembly) have been implemented. Existing RPC API functions (such as xs_get_assembly_list) have been updated to support rebar assemblies.
TTSD-46096 - The Developer Kit contains changes that break binary compatibility. However, source compatibility is preserved. RPC components must be recompiled to work again. These changes were requested to allow RPC components to support longer object names, material, part finish, and screw standard. You can now also add new properties to the components. The following changes have been made:
- The length of several string fields in the joint_parameter_s structure has been increased. These fields are: mat1-mat15, partname1-partname15, screwdin-screwdin10, pos, and rot.
TTSD-41876, TTSD-41877, TTSD-46999, TTSD-47002, TTSD-46581 - New double fields w1_other_size-w10_other_size and w1_other_size2-w10_other_size2 were added to the joint_parameter_s structure. These fields are used to show another size for compound welds.
TTSD-26926 - New string fields Finish1-Finish12 were added to the joint_parameter_s structure.
TTSD-25609
- The length of several string fields in the joint_parameter_s structure has been increased. These fields are: mat1-mat15, partname1-partname15, screwdin-screwdin10, pos, and rot.
Because the joint_parameter_s structure size was increased, you might need to increase application stack size depending on the application.
- A new function bool xsGetAttributeString(const std::string &Name, int FatherId, std::string &rStringValue) has been added. The function allows getting file names with lengths up to 256 characters and assumes to be used for variables of file name type for macro components.
TTSD-45707, TTSD-45708, TTSD-45546, TTSD-41889, TTSD-26519 - Previously, the function xs_staggered_bolt_list supported staggered type input in the interval 0-4. Now a new type 5 was added. When type 5 is passed as input, all inner bolts are filtered away and only bolts along the contour remain.
TTSD-41875 - When working with SAFE_STRCPY, and related macros and DString_c class, the syntax SAFE_STRCPY(Field, Name); is no longer allowed. The new syntax for these macros is SAFE_STRCPY(Field, Name.GetSafeString());
TTSD-45413