Tekla Structures 2019i Open API Release Notes

Updated: 16 Feb 2024

Tekla Open API release notes

TEKLA.STRUCTURES.ANALYSIS 2019.1.0.0 ASSEMBLY

TTSD-27061

GUID is now available (not empty) for AnalysisPart, AnalysisNode, and AnalysisNodeLink.

TTSD-26199

Tekla Structures now detects analysis engines with XML files (registry detection is still supported). This was done to enable the installation of analysis engines with TSEP packages. 

To detect analysis engines, a file named “EngineInfo.xml” has to be created. 

The file should look like this:

<Document> 

    <Name>TS20_ETABS2017_PLUGIN</Name> 

    <Label>ETABS v2017 (1.0)</Label> 

    <DotNet>1</DotNet> 

</Document> 

<Name> is the name of the plug-in. 

The rest behaves exactly like the settings that could have been set using the registry. 

This file needs to be placed in a separate folder for each engine in \environments\common\extensions\analysis_engines\<engine>\ 

Another folder apart from the \analysis_engines folder can be added by adding it to XS_ANALYSIS_ENGINE_PATH. Note that only first level subfolders will be scanned for XML files. ";" (semicolon) is the delimiter between the paths. So for example, if you have “EngineInfo.xml" in "C:\my_engines\test_engine\", then you would add ";C:\my_engines\" to  XS_ANALYSIS_ENGINE_PATH.

TEKLA.STRUCTURES.CATALOG 2019.1.0.0. ASSEMBLY

TTSD-22509

The Modify, Delete and Copy methods have been added to the LibraryProfileItem class.

TTSD-24601

The profile catalog now shows the correct profile string for selection. Note that the actual tree structure will still not be correct if the total tree path length is more than 130 characters.

TTSD-25695

Changes to existing profiles in import will now be effective immediately. Reopening the model is not needed anymore.

TTSD-26657

Rebar crank properties are now filled correctly when selecting a rebar item.

 

TEKLA.STRUCTURES.DIALOG 2019.1.0.0 ASSEMBLY

TTSD-10056

Support for long strings has been added to plug-in dialog boxes inherited from the PluginFormBase or PluginWindowBase classes. Before there was a limitation of 80 characters with stored strings, now the limitation has been removed. The long string is also passed to plug-in execution. Note that the maximum length of a string attribute name is 15 characters for long strings.

TTSD-26186

The related filter check box is now always checked if the property value is changed in Wpf dialog boxes which are inherited from the ApplicationWindowBase or PluginWindowBase classes.

 

TEKLA.STRUCTURES.DRAWINGS 2019.1.0.0. ASSEMBLY

TTSD-10056

Support for long strings has been added to the Plugin class in the GetAttribute() and SetAttribute() methods. Before, the limitation was 80 characters with strings, now the limitation has been removed.

TTSD-23229

In some cases, dimensions would not work correctly if modified with Open API. This has now been fixed.

TTSD-27154

GetModelObjects(Identifier id) now works if only the guid is set to identifier.

 

TEKLA.STRUCTURES.MODEL 2019.1.0.0. ASSEMBLY

TTSD-10056

Support for long strings has been added for plug-ins to the BaseComponent class in the GetAttribute() and SetAttribute() methods. Before the limitation was 80 characters with strings, now the limitation has been removed.

TTSD-24324

Tekla.Structures.Model.Collaboration now provides values correctly if an IFC model has been inserted with a base point.

TTSD-24739

Operation.IsNumberingUpToDate now works correctly for B-rep objects.

TTSD-25989

The IsNumberingUpToDateAll method returned false on a numbered cast unit column with a rebar set. This has now been fixed.

TTSD-24953

The PointCloud Open API class now has an option to attach by using auto created base point.

TTSD-25555

The RefModelObject.GetReportProperty method in the IFC ReferenceModelObject Open API class has been changed. The method does not try to cast strings to double or int anymore.

TTSD-27130

The GetDynamicStringProperty() and SetDynamicStringProperty() methods have been added to the ProjectInfo class for storing long string values to a project.

TTSD-28418

Previously, when accessing the number of points of a polygon weld welding bent plate, zero points were returned. This has now been fixed.

TTSD-28152

Previously, the Model.Loaded event could be fired too early when Tekla Model Sharing read in was executed. This has now been fixed.

 

TEKLA.STRUCTURES.PLUGINS 2019.1.0.0 ASSEMBLY

TTSD-24892

The coordinate system of the plug-in defined with custom attribute [PluginCoordinateSystem(CoordinateSystemType.FROM_FIRST_AND_SECOND_POINT)

is now updated correctly when input points are changed.

 

 

 

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.