Tekla Structures 2017i Open API Release Notes

Updated: 7 Feb 2024

This document explains new features, fixes and improvements in Tekla Open API 2017i.

For more examples and information, download Tekla Open API Reference Manual 2017i from Tekla Warehouse

Tekla Open API Release Notes.

Tekla.Structures.Catalog 2017.1.0.0 Assembly 

  • • Selection of the current material item has been added to the material enumeration. TT120981
  • The TSEP package builder application showed an error message when no errors had occurred if the package remove after install option was set to no. This has now been corrected. TTSD-3677

 Tekla.Structures.Model 2017.1.0.0 Assembly 

  • Previously, it was not possible to return secondaries of an assembly if the objects were bent plates in Open API. This has now been fixed. TTSD-4269
  • Previously, when the Tekla.Structures.Model.Operations.Operation.CreateBentPlat eByParts() method was used from inside a plug-in, it returned null, and the created bent plate had a new identifier. This has now been fixed. The Tekla.Structures.Model.Operations.Operation.CreateBentPlat eByParts(Part part1, Part part2) method now always returns a BentPlate object, whose identifier is the identifier of the first parameter. TTSD-4365
  • The RedrawWorkplane() method has been added to the ViewHandler class for redrawing the work plane symbol in the model view. TT130966
  • Points are now created correctly at the intersections of parts and lines. Previously, when the line intersected the part through a recess or a hole in the middle of a part face, an incorrect number of points was created. TTSD-3778, TT130495
  • Drawing Cyrillic characters to the model view from Open API works again. TTSD-4290
  • It is now possible to visualize model objects by using only identifiers. TT130887
  • New SpiralBeam class has been added to Open API for creating and modifying spiral stair case rails, for example. TTSD-1618 

Tekla.Structures.Drawings 2017.1.0.0 Assembly 

  •  The GetIntegerUserProperties() method now returns correct values for drawings. TTSD-5544
  • Weld marks added in a drawing were previously not recognized by Open API. Now they are. They can be differentiated from the weld marks originating from the model by their ModelIdentifier 0. TTSD-5417
  • The Drawings.GridLine GridLabelText property now returns the label correctly. TTSD-5780
  • It is now possible to print drawings to PDF through Drawing API. TTSD-2704 

Tekla.Structures.Analysis 2017.1.0.0

  •  Four enumerations have been added:
    • Sub-analysis parts of analysis parts (when main part, IsMainPart() is added)
    • Main analysis parts of analysis parts (when sub-part, IsSubPart() is added)
    • Analysis parts connected to nodes
    • Analysis node links connected to nodes TTSD-3589


 

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.