Tekla Structures 2016 Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 2016. For more examples and information, see Tekla Open API Reference Manual for version 2016. 

Tekla.Structures 2016.0.0.0 Assembly

Solid faces

  • Solid faces now have information about the object ID responsible for creating the face. For example, a face created by a part cut has the ID of the cutting object (that is, the anti-material object created by the part cut command). In Tekla Open API, the functionality is available as Tekla.Structures.Solid.Face.OriginPartId.

XS_EXTENSION_DIRECTORY

  • The XS_EXTENSION_DIRECTORY advanced option can be used for defining additional loading paths for model and drawing plug-ins. 

Tekla.Structures.Dialog 2016.0.0.0 Assembly

Rebar shape catalog

  • ReinforcementSelectionForm now selects the usage node on doubleclick and closes the Select reinforcing bar dialog box when the grade size is selected in Rebar shape catalog.

Reinforcing bar catalog

  • The reinforcing bar catalog (ReinforcementSelectionForm) now opens faster than before when launched from an Open API based extension dialog box. 

Plug-in dialog box and location

  • .NET plug-in dialog box size and location are now stored under the Tekla Structures version in the registry. 

Tekla.Structures.Model 2016.0.0.0 Assembly

New ModelHandler class

  • A new class, ModelHandler, has been added to the Tekla.Structures.Model assembly for saving, opening and creating new single and multi-user models. Old Open() methods in the Operations class have been marked as obsolete. 

Slotted hole values in IFC export

  • Slotted hole values are now always zero in the .NET interface if there are no slotted holes in the bolt, or if the bolt is a stud. 

Tekla.Structures.Model.UI namespace

  • An additional argument Showdimensions has been added to the Select() method in the ModelObjectSelector class. The default value is TRUE. If the value is set to FALSE, the dimensions are not drawn to the user interface when the part is selected. 
  • A new class, ModelObjectVisualization, has been added to Open API for model object visualization. The class can be used for setting temporary color and transparency values for a model object in the view. 

Changes in surface object API

  • When setting the polymesh for surface creation, the normal of the polymesh must point to the outside of a part or pour. This improves the performance of surface creation and optimizes the database size.
    The following changes have been made in the surface object API in Structures/DotNetInterface/Tekla.Structures.Model/Surface/ SurfaceObject.cs:
    • Public boolean SetParent(ModelObject obj) is called only before calling public override boolean Insert(). Calling SetParent() after Insert() may cause unexpected behavior.
    • FacetedBrep polymesh's normal should be pointing out from the material to optimize the performance and minimize the database size. Note that Tekla Structures uses the right-hand rule to determine the polymesh point order and polymesh normal. 

NC files

  • There is now a new function in Tekla Open API, GetDSTVCoordinateSystem(), which returns the coordinate system that is used to export the part.

Dynamic strings for model objects

  • It is now possible to set and get dynamic strings for model objects using the following methods:
    • public boolean SetDynamicStringProperty (string name, string value);
    • public boolean GetDynamicStringProperty (string name, string value);

Tekla.Structures.Drawings 2016.0.0.0 Assembly

Drawing text objects

  • The maximum number of characters allowed in drawing text objects is now 8192 both in the drawing and in Tekla Open API. 

Dual dimension units

  • Previously, dual dimension units were not working when accessed through the .NET interface, now they are.
    A dual dimension is a special text written on the Tags tab in the dimension properties dialog box.
    If you write the text DIMENSION for one of the tags, the dimension length value is placed for that tag in its place.
    When accessed through the .NET interface, using one of the tags ContainerElements, it will contain a TextElement with the text value of DIMENSION if a dual dimension value is found.
    Tekla Structures 2016 Open API Release Notes 5
    Note that if dual dimensions are wanted in a tag, only one element can exist in the tag and it has to be the TextElement containing DIMENSION

Setting arrow head type

  • When modifying marks through the drawings .NET interface, the arrow head type could not be set, now it can be set.
    Note that the width and height of mark arrow heads can still not be set, as those values are defined in advanced options only, see XS_MARK_LEADER_LINE_ARROW_HEIGHT and XS_MARK_LEADER_LINE_ARROW_LENGTH

Weld marks

  • It is now possible to modify the weld mark insertion point and leader line through Tekla Open API. 

Layout attributes

  • Previously, Layout and Table Layout values were not applied correctly through Drawing.Modify after calling LoadAttributes for LayoutAttributes, now they are. 
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.