Tekla Structures 20.1 Open API Release Notes
Updated:
13 May 2019
This document explains new features, fixes and improvements in Tekla Open API 20.1. For more examples and information, see Tekla Open API Reference Manual for version 20.1.
Tekla.Structures.Model 20.1.0.0 Assembly
New class: ControlCircle
- Direct modification of construction circles is now enabled in Tekla Open API via the new
ControlCircle
class.
Construction lines
- Tekla.Structures.Model.UI.ModelObjectSelector().GetSelectedObjects() now works with ControlLines.
User-defined attributes in reference model parts
- Previously, reference model parts could not be assigned a user-defined attribute if they were accessed through
ModelObjectEnumerator
and were not selected, that is,SelectInstances
in the enumerator was set to false.
New method: GetAllIntersectionPoints
- The
Solid
class has a new methodGetAllIntersectionPoints
that gets all the intersection points between the solid and a plane. Compared to theIntersectAllFaces
method, it does not arrange the points into polygons, and is thus a lot faster.
Tekla.Structures.Drawings 20.1.0.0 Assembly
New command: UpdateDrawing
- The
UpdateDrawing
command has been added to theDrawingHandler
class. This command allows the non-up-to-date drawings in the drawing list to be updated as if used from the user interface.
New property: ExcludePartsAccordingToFilter
- A new property,
ExcludePartsAccordingToFilter
, is now available:- You can set the filter to be used for
StraightDimensionSet
tags. - If an invalid
ExcludePartsFilter
is given, it will becomeNone
. StraightDimensionSet.GetAllExcludePartsAccordingToFilter()
queries the availableExcludePartsAccordingToFilters
.
- You can set the filter to be used for
FixedViewPlacing set correctly
LoadAttributes
now sets theFixedViewPlacing
property correctly.
Assembly, cast unit and single part drawings
AssemblyDrawing
,CastUnitDrawing
(both by id and by position) andSinglePartDrawing
can now be created and inserted. Insert always inserts the drawing using the view creation rules. Views are added as defined by the rules. Constructors that take a sheet number have also been added.
Drawing views
- When modifying a view, the drawing plug-ins inside the view are now also updated.
Tekla.Structures.Dialog 20.1.0.0 Assembly
Distance field units
- Tekla Open API plug-ins now initialize distance field units correctly and also update them when re-opened after the user has changed the unit settings.