Tekla Structures 20.0 Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 20.0. For more examples and information, see Tekla Open API Reference Manual for version 20.0.

 

Tekla.Structures 20.0.0 Assembly

New class: TeklaStructuresFiles

  • A new class, TeklaStructuresFiles, has been added to Tekla Open API. The new class is used for fetching files from the Tekla Structures environment based on name or suffix.

Tekla.Structures.Model 20.0.0 Assembly

New property: TypeName

  • A new property, TypeName, has been added to the Surfacetreatment class in Tekla Open API. The new property is used for defining the name of the surface treatment type. If the value differs from the UI name in the dialog option field, an empty field is shown in the UI, but the value is still stored to the database. 

Support for temperature loads

  • Tekla Open API now supports temperature loads.

 Support for B-rep parts

  • A new class, Brep, has been added to the interface for manipulating part items in Tekla Structures.

Support for polygon points

  • The LoadUniform class now has support for inserting new polygon points and deleting existing polygon points.

Support for high-accuracy solids

  • The Solid.IntersectAllFaces() method now allows you to use high-accuracy solids. Earlier, high-accuracy solids were only supported by Part.GetSolid(), Solid.Intersect(LineSegment), and Solid.Intersect(Point, Point).
    We do not recommend using the Solid.Intersect method. Use Solid.IntersectAllFaces instead. 

New methods for retrieving all user and report properties

  • The following two new methods for retrieving all user and report properties have been added to the interface for all model object classes:
    public bool GetAllReportProperties(ArrayList StringNames, ArrayList DoubleNames, ArrayList IntegerNames, ref Hashtable Values)
    and
    public bool GetAllUserProperties(ref Hashtable Values)

New default for fetching rebar geometries

  • Model API: Rebar geometries are now fetched in deformed form by default.

Improved examples for the CreateFitting method

  • The examples for the CreateFitting method in the ConnectionBase class and the CustomPartBase class are now more comprehensive than in the previous versions.

New weld class properties

  • The Weld class now has new properties for setting the direction and preparation type.

View coordinate system corrected

  • Previously, the view coordinate system was incorrect in View.Select(), if the work plane was not in the global origin. This has now been fixed.

Opening autosaved versions of multi-user models

  • Opening autosaved versions of multi-user models now works through the Tekla Open API. Previously, opening autosaved versions worked only with single-user models.

Tekla.Structures.Drawings 20.0.0 Assembly

Values for angle dimension and radius dimension corrected

  • The GetUnformattedString() method now returns correct values (no additional characters) for angle dimension and radius dimension.

Values of marks returned for PropertyElements

  • TagsAttributes.TagContent for DetailMark, SectionMark, and View now returns the values of the marks in the case of PropertyElements.

Method removed from StartUp package: StraightDimensionSet.Insert()

  • The StraightDimensionSet.Insert()method has been removed from DimensionCreator in the Tekla Open API StartUp Package.

Hatch name does not need to be specified

  • The HatchAttributes class now accepts an empty string for the hatch name property, however, it will convert the string to None.

Tekla.Structures.Dialog 20.0.0 Assembly

Improvement in profile catalog control

  • Profile catalog control in Tekla Structures.Dialog.dll now shows profile items in a structure similar to core side profile catalog control, if the father form is inherited from PluginFormBase or ApplicationFormBase.

Tekla.Structures.Catalogs 20.0.0 Assembly

Exporting and importing  user-defined parametric profiles

  • Export and import of user-defined parametric profiles (.clb) has been added to Tekla Open API.

New methods for bolt assembly export and import

  • Bolt assembly export and import methods have been added to the catalog interface in Tekla Open API:
    The ExportBoltStandard() method has been added to the BoltItem class.
    The ImportBoltItems(string path) method has been added to the CatalogHandler class.

New methods for rebar catalog export and import

  • Rebar catalog item export and import methods have been added to the catalog interface in Tekla Open API. 

New methods for mesh catalog item export and import

  • Mesh catalog item export and import methods have been added to the catalog interface in Tekla Open API.

New classes and methods for drawing catalog

  • The DrawingItem and DrawingItemEnumerator classes have been added to the interface for enumeration and exporting drawing settings used in the drawing creation functionality. 

New classes added to shape catalog 

  • The ShapeItem and ShapeItemEnumerator classes have been added to the interface for enumeration and exporting shape geometry definitions used in the part item functionality. Shape definitions are used in the creation of new B-rep objects through Tekla Open API. 

New method for exporting shapes

  • New Export() method has been added to the ShapeItem class for exporting shapes from the shape catalog. 

New method for importing multiple shapes

  • New ImportShapes() method has been added to the CatalogHandler class for importing multiple shapes from a folder.

Documentation improvements

  • Tekla Open API Reference: The CustomPart example for the CustomPart class has been corrected.
  • Tekla Open API StartUp Package: Example of dimension when picking points has been improved to mention "Pick point in part/object". 
  • Tekla Open API StartUp Package: Because Plugins.dll is not installed in GAC any more, HintPath was corrected in the examples. In addition to changes to HintPath, some other changes were made to project files to make them easier to understand.

 

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.