Tekla Structures 19.1 Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 19.1. For more examples and information, see Tekla Open API Reference Manual for version 19.1.

 

Tekla.Structures 19.1.0.0 Assembly

New method in TeklaStructuresInfo class: GetCurrentUser()

  • It is now possible to identify the current user through Tekla Open API by using the new GetCurrentUser() method in the TeklaStructuresInfo/code> class.

New class: OBB

  • A new class, OBB, has been added to Tekla Open API. The new class allows, for example, the calculation of intersections between different geometric primitives. For more information and examples see the class documentation in the Tekla Open API Reference Manual for version 19.1.

 Tekla.Structures.Model 19.1.0.0 Assembly

Modifying cuts and added material

  • Cuts and added material with contour plate profiles can again be modified through Tekla Open API.

Creating contour plates

  • The contour plates created through Tekla Open API now work as follows:
    • Polygons defined in the counterclockwise direction (as seen from the xy plane) are not rotated when created.
    • Polygons defined in the clockwise direction (as seen from the xy plane) are rotated and reversed to form a clockwise polygon.
    • Polygons defined in the local z plane (perpendicular to the xy plane) are never rotated, regardless of the orientation.
  • Chamfers now stay in the correct positions in all situations.

Showing Tekla Structures Version

  • Tekla Open API now shows the Tekla Structures version label text (for example, 19.0.1) instead of the version text (for example, 19.0.x).

Modified Model.ReferenceModel Object methods

  • The GetChildren() method has been modified so that when a reference assembly node is selected, it will return all the children parented under the assembly node.
    The GetFather() method has been added. The method will return a reference to the assembly father if such exists, or a null reference. 

Changing contour plate position using the Modify() operation

  • It is now possible to change the position of a contour plate if the plate is parallel to the xy plane by triggering the Modify() operation. 

User-defined attributes for reinforcements

  • User-defined attributes for reinforcements are now updated before (not after) any connected components are triggered. This prevents accidental overwriting of component results. 

Creating reinforcements to a deformed part

  • It is now possible to inquire solid data in different forming states and also to define the input point deforming state when creating or modifying reinforcement. Previously, when creating reinforcement to a deformed part, the reinforcement was not placed correctly.

New method in part class: GetPours

  • A new method, GetPours, has been added to the Part class. The method returns an enumerator of all the pours that the part belongs to. 

Adding a custom part to an assembly: Assembly.Add(CustomPart)

  • When adding a custom part to an assembly through Tekla Open API (Assembly.Add(CustomPart)), the assembly is now automatically updated to contain the new subassembly. The subassembly is created because of the added custom part.

Faster solid enumeration

  • The FaceEnumerator for solid enumeration now works considerably faster than before for applications that are not running on the same process with Tekla Structures. 

Data on solids for reinforcing bars

  • Data on solids can now be fetched for reinforcing bars through Tekla Open API. 

EdgeEnumerator in the solid interface

  • The solid interface in Tekla Open API now has the EdgeEnumerator that returns edge data. This edge data includes the edge type, edge start point, and edge end point.

New method in Boltgroup class: Getsolid

  • A new method, GetSolid(bool UseHighAccuracy = false), has been added to the BoltGroup class.

Component GUIDs

  • Component GUIDs are now set correctly when inserting components.

New method in Tekla.Structures.Model.UI.ModelObjectSelector class: GetObjectsByBounding-Box

  • A new method, GetObjectsByBoundingBox(Point MinPoint, Point MaxPoint, View View), has been added to the Tekla.Structures.Model.UI.ModelObjectSelector class. The method can be used to get an enumerator of the given view's visible model objects that collide with the given geometrical bounding box. 

Methods for weld solid and weld seam-specific geometries

  • Tekla Open API now provides methods for getting weld solid and weld seam-specific geometries. There are also new properties for welds.
    A new class, WeldGeometry, has been added to Tekla Open API with the following properties:
    • Position (above or below)
    • Polygons (ArrayList of weld seam-specific polygon objects)
  • The following changes have been made in the BaseWeld class: 
    • A new method, GetSolid(), has been added. The usage is similar to the GetSolid() method in the Part class. 
    • A new method, GetWeldGeometries(), has been added. The method returns an ArrayList of WeldGeometry objects. The WeldGeometry objects represent weld seamspecific geometry.
    • New properties have been added: IntermittentType, Placement, IncrementAmountAbove, and IncrementAmountBelow.

Model north direction set correctly in drawings

  • Re-opening a model now works correctly if the NorthDirection property is set in the ProjectInfo class. Previously, an incorrect value for the model north direction was set in drawings. 

Tekla.Structures.Drawings 19.1.0.0 Assembly

Dimension middle tag

  • The MiddleLowerTag value is now transferred to StraightDimensionSet during updates through Tekla Open API.

Tekla.Structures.Dialog 19.1.0.0 Assembly

Plug-in attribute file names

  • Plug-in attribute names can now contain the following characters ".", for example, "a.a".

New user control in Tekla.Structures.Dialog.dll: CreateApplyCancel

  • There is a new user control, CreateApplyCancel, in Tekla.Structures.Dialog.dll to be used with non-dependent plug-in UIs. There are three buttons for user control: Create, Apply, and Cancel

Opening several plug-ins

  • Trying to open several plug-in instances by quickly double-clicking on the plug-in icon in the plug-in catalog does not cause plug-ins to crash or the application to freeze anymore. 

 Tekla.Structures.Catalogs 19.1.0.0 Assembly

Importing and exporting catalog items

  • Import from folder has been added for LibraryProfileItems, ParametricProfileItems, MaterialItems, and custom components. The Export() method has been added to the corresponding catalog items. 

 New enumerator: MaterialMarketSizesItemEnumerator

  • The new enumerator MaterialMarketSizesItemEnumerator reads the data from the XC_PROFDB/marketsizes.dat file. The enumerator enumerates through a collection of MaterialMarketSizesItems.
    MaterialMarketSizesItem contains the following properties:
    • MaterialName
    • MarketSizes, containing an array of doubles representing the possible marketsize values for a particular material.

If MaterialMarketSizesItemEnumerator initialization fails (for example, the file could not be read), a CatalogItemEnumeratorInitializationException is thrown. The exception contains an appropriate error message and also an inner exception (a more specific cause for the problem).
MaterialMarketSizesItemEnumerator usage is similar to other catalog enumerators. For an example, see the Tekla Open API Reference Manual.

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.