Plugins (.dll)

Updated: 6 Aug 2020

Plugins are component tools used to, for example, automate creation of model or drawing objects.

Plugins are loaded inside the Tekla Structures process. In Tekla Structures, start Plugins from the Applications & components catalog.

The Tekla.Structures.Plugins assembly provides for example following classes for creating plugins:

Class               Description
PluginBase   An abstract base class for component tools.

PluginFormBase

 

 

 

 

 

 

 

A base class for plugins that use Windows Forms for dialog design. Class adds the following support:

  • .Net dialogs

  • Data connections

  • Tekla Structures data types and conversions automatically

  • Multiple language support

  • Storing of default values

     

ConnectionBase

  A base class for defining Connections, Details and Seams. These types are more specialized and restricted by the input values than the ones derived from PluginBase.

CustomPartBase

  A base class for defining custom parts.

DrawingPluginBase

  An abstract base class for drawings plugins. Contains the user-interface and the dialog using the PluginFormBase.

 

The Tekla.Structures.Dialog namespace contains classes and methods that enable, for example, dialog creation for Tekla Structures plugins and localization of dialogs.

Class               Description
PluginWindowBase   A base class for plugin WPF dialogs. The class extends the WindowBase class by adding communications with Tekla Structures.
PluginFormBase   A base class for plugin Form dialogs. The class extends the FormBase class by adding communications with Tekla Structures.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.