Add directives to namespaces of Tekla Structures assemblies

Updated: 13 May 2019

To use the classes and methods of Tekla Open API, you need to add directive lines to your code.

Add directives to namespaces of Tekla Structures assemblies

  1. Right-click Form1.cs in the Solution Explorer.

  2. Select View code on the pop-up menu.

  3. Add the using directive lines. You can also create alias for a namespace. For example: 
    using Tekla.Structures.Model;
    ​​using TSG = Tekla.Structures.Geometry3d; 

The Tekla.Structures.Model namespace includes the functionality to insert, select, modify or delete objects inside a Tekla Structures model. The namespace also includes possibilites to query different kind of data from the current model instance, such as information about the currently selected objects.

The Tekla.Structures.Geometry3d namespace includes the required basic 3D geometric classes that Tekla Structures uses.

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.