Tekla.Structural.InteropAssemblies.TeddsCalc Namespace |
Tekla Tedds Calculator API
The Tedds Calculator is the application which performs the actual calculation processing, it can be used to evaluate single mathematical expressions or to evaluate complete calculations.
The Tedds Calculator is an Out-of-process COM Server TeddsCalc.exe which means it can be used from both 32-bit and 64-bit processes.
The Tekla.Structural.InteropAssemblies.TeddsCalc namespace contains the classes and types required to use the Tedds Calculator API.
Interfaces
Interface | Description | |
---|---|---|
ICalculator |
Interface for the main Tedds Calculator
| |
ICalculatorExEvents |
Interface for Calculator events.
| |
ICalcValue |
Interface for an ICalcValue, the fundamental data type used by the calculator for input and output values
| |
IFunctions |
Interface for executing calculation commands
|
Enumerations
Enumeration | Description | |
---|---|---|
CalcErrorType |
Error types
| |
CalcProgressEvent |
Progress bar modes
| |
CalcStatus |
Calculate status codes. Values less than zero are considered failures, values greater than zero are considered successful.
| |
CalcValueFormat |
Formats for converting numeric values to a string
| |
CalcValueType |
Value data types
| |
OutputFormat |
Document output formats
| |
VariableFormat |
Data formats for variables, currently only XML format is supported
|