Tekla.Structural.InteropAssemblies.Tedds Namespace |
Tekla Tedds Application API
The Tedds Application API allows you to automate tasks using the features of the Tedds Application. For example you can create a project, add new documents, calculate those documents and convert final output documentation to PDF format. You cannot directly provide input variables to a calculation using just the Tedds Application. However by using the Tedds Calculator you can generate input variables and pre-calculated output which can then be used with the Tedds Application to create Tedds documents.
The Tedds Application is an Out-of-process COM Server Tedds.exe which means it can be used from both 32-bit and 64-bit processes.
The Tekla.Structural.InteropAssemblies.Tedds namespace contains the classes and types required to use the Tedds Application API.
Interface | Description | |
---|---|---|
_IApplicationEvents |
Interface for Tedds application events
| |
IApplication |
Interface for the Main application
| |
IBimProject |
BIM project
| |
ILibraryCalcItem |
Interface for a library calc item
| |
IProjectFileItem |
Interface for a project file item
| |
IProjectFolderItem |
Interface for a project folder
| |
IProjectItem |
Interface for a project item
| |
IProjectItems |
Interface for a collection of Project items
| |
ITeddsDocument |
Interface for an open Document
| |
ITeddsDocuments |
Interface for a collection of open documents
| |
ITeddsProject |
Interface for a project
|
Enumeration | Description | |
---|---|---|
TdsCalcStatus |
Calculation status
| |
TdsProjectSavePdf |
Save project to PDF options
| |
TdsSaveOptions |
File save options
| |
TdsWindowState |
Window state
|