ITeddsProject Interface |
Interface for a project
Namespace: Tekla.Structural.InteropAssemblies.Tedds
Assembly: Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 26.0.0.1
Syntax
The ITeddsProject type exposes the following members.
Properties
Name | Description | |
---|---|---|
BimProject |
Linked BIM project
| |
FullName |
Full path of project file including file name
| |
IsOpen |
Is a project currently open
| |
Name |
Project name
| |
Path |
Project file path (excludes file name)
| |
RootFolder |
Root folder in the project tree
| |
Saved |
Saved status of project file
|
Methods
Name | Description | |
---|---|---|
Calculate |
Calculate all documents in the project
| |
Close |
Close the active project
| |
New |
Create a new project
| |
Open |
Open an existing project
| |
Save |
Save the active project file
| |
SaveAs |
Save the active project file to a new location
| |
SaveAsPdf |
Save all the documents in the project in PDF format
| |
SendToWord |
Export the project to Microsoft Word or Tedds for Word
| |
SetBimProject |
Link the Tedds project to a BIM project
|
See Also