ITeddsDocuments Interface |
Interface for a collection of open documents
Namespace: Tekla.Structural.InteropAssemblies.Tedds
Assembly: Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 26.0.0.1
Syntax
The ITeddsDocuments type exposes the following members.
Properties
Name | Description | |
---|---|---|
Count |
Returns the number of documents in the collection
| |
Item |
Returns a single document in the collection
|
Methods
Name | Description | |
---|---|---|
Add |
Add a new document
| |
Add2 |
Add a new document using the specified Calc Item and input variables
| |
Add3 |
Add a new document using the specified Calc Item, input variables and pre-calculated RTF
| |
Close |
Close all documents
| |
GetEnumerator |
Enumeration interface for iterating the items in the collection
| |
Open |
Open an existing document
| |
Save |
Saved changes to all open documents
|
See Also