IProjectItems Interface |
Interface for a collection of Project items
Namespace: Tekla.Structural.InteropAssemblies.Tedds
Assembly: Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 26.0.0.1
Syntax
The IProjectItems type exposes the following members.
Properties
Name | Description | |
---|---|---|
Count |
Return the number of items in the collection
| |
Item |
Returns a single item in the collection
|
Methods
Name | Description | |
---|---|---|
AddDocument |
Add an existing open document to the end of the collection of project items
| |
AddFile |
Add a reference to a Tedds document file to the end of the collection of project items
| |
AddFolder |
Add a new folder to the end of the collection of project items
| |
AddFromPath |
Add a single Tedds project file or a complete folder hierarchy from a full file path
| |
GetEnumerator |
Enumeration interface for iterating the items in the collection
| |
Remove |
Remove a project item from the collection
|
See Also