IFunctions Interface |
Interface for executing calculation commands
Namespace: Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly: Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 26.0.0.1
Syntax
The IFunctions type exposes the following members.
Methods
Name | Description | |
---|---|---|
AddSection |
Add a new variable section using the Tedds 'AddSection' function.
For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at
"Writing your own custom calculations\Calculation writing documentation\Tedds functions"
| |
Eval |
Returns the result of calculating an expression using the Tedds 'Eval' function.
For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at
"Writing your own custom calculations\Calculation writing documentation\Tedds functions"
| |
GetVar |
Returns the value of a named variable using the Tedds 'GetVar' function
| |
SetSection |
Set the active variable section using the Tedds 'SetSection' function.
For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at
"Writing your own custom calculations\Calculation writing documentation\Tedds functions"
| |
SetVar |
Assigns a value to the named variable using the Tedds 'SetVar' function.
For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at
"Writing your own custom calculations\Calculation writing documentation\Tedds functions"
| |
SetVarExpr |
Assigns an expression value to the named variable using the Tedds 'SetVar' function.
For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at
"Writing your own custom calculations\Calculation writing documentation\Tedds functions"
| |
VarExists |
Returns true if the named variable already exists using the Tedds 'VarExists' function.
For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at
"Writing your own custom calculations\Calculation writing documentation\Tedds functions"
|
See Also