ICalculator Interface |
Interface for the main Tedds Calculator
Namespace: Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly: Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 26.0.0.1
Syntax
The ICalculator type exposes the following members.
Properties
Name | Description | |
---|---|---|
CalculatingErrorEvents |
Determines whether error events are fired to the event listeners
| |
CalculatingProgressEvents |
Determines whether progress events are fired to the event listeners
| |
Functions |
Returns an object supporting the IFunctions interface which is used to access the internal Tedds calculator
functions
| |
Status |
Returns the status of the Tedds calculator when the last evaluation finished.
| |
UndefinedVariableEvents |
Determines whether undefined variable events are fired to the event listeners
| |
VersionLibraryMajor |
Returns the major version number of the Tedds Engineering Library
| |
VersionLibraryMinor |
Returns the minor version number of the Tedds Engineering Library
| |
VersionMajor |
Returns the major version number of the Tedds software
| |
VersionMinor |
Returns the minor version number of the Tedds software
| |
WindowHandle |
Returns the Tedds calculator's main window handle
|
Methods
Name | Description | |
---|---|---|
CopyOutputToClipboard |
Copies the output item to the Windows clipboard in the specified format
| |
GetOutput |
Returns the documented output from the calculator in the specified format.
| |
GetVariables |
Returns all the variables defined in the calculator excluding temporary variables
| |
GetVariables2 |
Returns the current Document and Calc Section variables in the specified data format
| |
GetVariables3 |
Returns the current Document and Calc Section variables in the specified data format
| |
Initialize |
Initializes the calculator to start calculating
| |
InitializeCalc |
Initializes the calculator and starts calculating using the specified Calc Library Item
| |
SetForegroundWindow |
Executes the Windows API function
SetForegroundWindow
from the Tedds calculator process.
| |
SetOwnerWindow |
Sets which window owns the Tedds calculator's main window
| |
SetVariables |
Assign the specified variables to the calculator instance
|
See Also