ICalcValue Interface |
Interface for an ICalcValue, the fundamental data type used by the calculator for input and output values
Namespace: Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly: Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 26.0.0.1
Syntax
The ICalcValue type exposes the following members.
Properties
Name | Description | |
---|---|---|
Degrees |
Returns the linear degrees dimension of the object. Only applicable for objects of type Number.
| |
IsDimensionless |
Returns whether the units of a numeric object has dimensions. Only applicable for objects of type Number.
| |
Length |
Returns the length dimension of the object. Only applicable for objects of type Number.
| |
Mass |
Returns the mass dimension of the object. Only applicable for objects of type Number.
| |
Time |
Returns the time dimension of the object. Only applicable for objects of type Number.
| |
Type |
Returns the objects data type
|
Methods
Name | Description | |
---|---|---|
ToBool |
Returns the objects value converted to a boolean. Only applicable for objects of type Number.
| |
ToDouble |
Returns the objects value converted to a double. Only applicable for CalcValue objects of type Number.
| |
ToInt |
Returns the objects value converted to an integer. Only applicable for CalcValue objects of type Number.
| |
ToString |
Returns the objects value represented as a string.
|
See Also