IApplication Interface |
Interface for the Main application
Namespace: Tekla.Structural.InteropAssemblies.Tedds
Assembly: Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 26.0.0.1
Syntax
The IApplication type exposes the following members.
Properties
Name | Description | |
---|---|---|
ActiveDocument |
Returns active document
| |
Build |
Returns the version build number of the Tedds software
| |
Documents |
Returns A Documents collection which represents all the open documents
| |
Height |
Height of the applications main window
| |
Left |
Position of the left edge of the applications main window
| |
Project |
Returns the active project
| |
Top |
Position of the top edge of the applications main window
| |
Version |
Returns the version number of the Tedds software
| |
VersionLibraryMajor |
Returns the major version number of the Tedds Engineering Library
| |
VersionLibraryMinor |
Returns the minor version number of the Tedds Engineering Library
| |
VersionMajor |
Returns the major version number of the Tedds software
| |
VersionMinor |
Returns the minor version number of the Tedds software
| |
Visible |
Visibility status of the applications user interface
| |
Width |
Width of the applications main window
| |
WindowHandle |
Returns the window handle of the applications main window
| |
WindowState |
View state of the applications main window
|
Methods
Name | Description | |
---|---|---|
Activate |
Activates the user interface of the application
| |
Move |
Move the applications main window
| |
Quit |
Exit the application
| |
Resize |
Size the applications main window
|
See Also