ICalculatorGetVariables3 Method

Returns the current Document and Calc Section variables in the specified data format

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 26.0.0.1
Syntax
string GetVariables3(
	VariableFormat format = VariableFormat.Xml,
	bool includeTemporaryVariables = false,
	bool includeModifiedAttribute = false
)

Parameters

format (Optional)
Type: Tekla.Structural.InteropAssemblies.TeddsCalcVariableFormat
Format in which to return the variables, the default is XML
includeTemporaryVariables (Optional)
Type: SystemBoolean
Determines whether to include temporary variables
includeModifiedAttribute (Optional)
Type: SystemBoolean
Determines whether to include the modified attribute for each variable

Return Value

Type: String
A string which defines the variables and their associated values and attributes
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next